Trap Runner Boxed Ve Vesalia

Benutzer
Benutzername:

Passwort:

 Automatisch einloggen



Ich habe mein Passwort vergessen!

Noch keinen Account?
Du kannst Dich KOSTENLOS registrieren!

Sprache:

 

» Home
» Heft Member
» News lesen
» News melden
» News Einstellung
» Everywhere
 
Amiga Future
» Info
» Inhaltsangaben
» Artikeldatenbank
» Merchandising
» Shop
» Download
 
Community
» Forum
» Galerie
» Kalender
 
Wissen
» Amiga Software
» Amiga Cheats
» Amiga FAQ
» Forum FAQ
» Link-Sammlung
 
Service
» Jobs
» Webmaster
» Werbung
» Kontakt/Impressum
» Datenschutz

Suchen

Erweiterte suche

Anzeigen
Bitte unterstützt uns durch Einkäufe bei Amazon:

Deutschland
Österreich
UK
France
Canada
Italia
Espana


Spenden
Donate
Amiga Future

Strange DNS lookup issue wrong name and IP resolved

 
Neues Thema eröffnenNeue Antwort erstellen Amiga Future Foren-Übersicht -> Roadshow Support
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen 
Autor Nachricht
theconfusedone
Grade reingestolpert
Grade reingestolpert


Anmeldungsdatum: 15.04.2019
Beiträge: 2


BeitragVerfasst am: 15.04.2019 - 13:01    Titel: Strange DNS lookup issue wrong name and IP resolved Zitieren

Hi,

Something has changed so that roadshow is now not resolving names correctly. I have not changed the roadshow configuration so am guessing that I either didn't set it up correctly to start with - and it worked by luck - or there has been a more general change to dns which is now causing things to fail.

The problem.

If I ping google from shell I get a name resolution of google.essex.com indeed if I ping any name, including pc names on my local network, I get this strange domain appended to the name.

The domain line in name_resolution is commented out - uncommenting this and adding, for a test, .co.uk results in 'unknown host' errors if I ping google or anything else even if it has a domain that ends .co.uk, eg the BBC.

In the past pinging google resulted in ping back from their dns server (8.8.8.8)

traceroute google (or indeed anything) shows the same odd behaviour with this essex.com domain name added. Also the () ip address is always the same (64.x4.xx8.xx) no matter what I try and traceroute.

This is not my router which is correctly identified in the first reply in traceroute, but then it goes out into the internet through my isp's gateways and eventually fails.

However some things do work. I get my amiga's time from an internet time server and that works. General internet browsing via Ibrowse (provided it does not try and grab an https site as this is broken for me) works so I can do google searches. Netsurf works on https sites so I can look at the BBC or many other modern sites.

This is daft. If my DNS is broken, as it looks, how can browsers resolve names???

Has anyone got any idea what is going on? I am baffled.
Nach oben   PDF
Benutzer-Profile anzeigen Private Nachricht senden
olsen
CygnusEd Developer


Anmeldungsdatum: 06.06.2006
Beiträge: 114


BeitragVerfasst am: 22.04.2019 - 12:30    Titel: Re: Strange DNS lookup issue wrong name and IP resolved Zitieren

theconfusedone hat folgendes geschrieben
Hi,

Something has changed so that roadshow is now not resolving names correctly. I have not changed the roadshow configuration so am guessing that I either didn't set it up correctly to start with - and it worked by luck - or there has been a more general change to dns which is now causing things to fail.

The problem.

If I ping google from shell I get a name resolution of google.essex.com indeed if I ping any name, including pc names on my local network, I get this strange domain appended to the name.


Normally, you need to provide a combination of host name + domain name for Roadshow (or any other TCP/IP stack) to look up the associated network address.

If you only provide the host name, then Roadshow will try to find a line in the "DEVS:Internet/hosts" file which matches that name.

Should nothing in the "hosts" file match the host name, the next step is to add a domain name to the host name. That domain name can be set in the "DEVS:Internet/name_resolution" file, using either the "domain" or "search" keywords, followed by that domain name (the "search" keyword can be followed by more than one name whereas the "domain" keyword is restricted to a single name).

Roadshow ships with "DEVS:Internet/hosts" and "DEVS:Internet/name_resolution" files which contain no specific name resolution instructions. These files are for you to edit as needed.

This explains why a domain name is added to a plain host name, but not where the "essex.com" domain name comes from. Say, are you using the automatic (DHCP) configuration option for your network interface?

The automatic configuration process will ask the DHCP server (typically, that device is provided by your Internet service provider, and it connects your home network to the Internet) which assigns a network address your Amiga to provide additional information, too. This additional information covers name resolution, and this is where the "essex.com" probably comes from. The server provides it, and it will be used as if you had entered "domain essex.com" in the "DEVS:Internet/name_resolution" file.

Zitat:

The domain line in name_resolution is commented out - uncommenting this and adding, for a test, .co.uk results in 'unknown host' errors if I ping google or anything else even if it has a domain that ends .co.uk, eg the BBC.

In the past pinging google resulted in ping back from their dns server (8.8.8.8)

traceroute google (or indeed anything) shows the same odd behaviour with this essex.com domain name added. Also the () ip address is always the same (64.x4.xx8.xx) no matter what I try and traceroute.

This is not my router which is correctly identified in the first reply in traceroute, but then it goes out into the internet through my isp's gateways and eventually fails.

However some things do work. I get my amiga's time from an internet time server and that works. General internet browsing via Ibrowse (provided it does not try and grab an https site as this is broken for me) works so I can do google searches. Netsurf works on https sites so I can look at the BBC or many other modern sites.

This is daft. If my DNS is broken, as it looks, how can browsers resolve names???

Has anyone got any idea what is going on? I am baffled.


If entering a plain host name ("google") always gives unpredictable results, but adding a specific domain name to that host name ("google.co.uk") works as expected, then the problem is likely with the domain name the TCP/IP stack tacks onto the plain host name.

I take it that you currently have no direct control over what that domain name being tacked onto the host name is. To make matters worse, Roadshow currently offers no means to state that the domain name should be empty, or that the DHCP server's choice of domain name should be ignored.

My advice for now would be to avoid using plain host names altogether and to always add a specific domain name to it. That way, there should be no room for misinterpretation.

The next step would be to figure out what your network's DHCP server (which assigns the network address to your Amiga) is configured to offer once an address has been assigned. If you have no control over it, your ISP or building management may be responsible for fixing the setup.
Nach oben   PDF
Benutzer-Profile anzeigen Private Nachricht senden
theconfusedone
Grade reingestolpert
Grade reingestolpert


Anmeldungsdatum: 15.04.2019
Beiträge: 2


BeitragVerfasst am: 22.04.2019 - 13:26    Titel: Zitieren

Hello Olsen,

Many thanks for such a detailed and helpful reply.

I have 2 configurations for Roadshow, one with a fixed IP address and one with a dynamic one.

I used the fixed for transferring data between pc and Amiga and the dynamic for when I am just internetworking with the Amiga.

You are correct if I ping google.co.uk then I get a correct resolution but just google gives this odd .essex.co.uk domain as does just using the pc' name.

This would solve the problem if I was running a dns on my local network and so could give the pc a domain. However I am not and use Smbfs when transferring files between PC and Amiga. Unfortunately this needs a machine name and just does not work if you supply a direct ip. Not you might think a problem, just add the pc's name to the hosts file with its ip address.

Except...

I have now discovered that Windows 7 pro is refusing to allow me to set a fixed IP address on the PC. When I do so it sets the previously private network to public and unknown and disables all shares.

I have tried various suggested fixes I found on the net for this but none worked.

If I set the PC to a dynamic IP my router gives it a new IP each time I turn on. So currently I am having to ask the pc what its IP address is and then put this in the roadshow hosts file every time.

Any suggestions how I might be able to get around this? Is there any way of faking a domain somehow, or some other way to get the PC and Amiga to communicate?
Nach oben   PDF
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnenNeue Antwort erstellen Amiga Future Foren-Übersicht -> Roadshow Support
Alle Zeiten sind GMT - 11 Stunden
Seite 1 von 1

PDF


Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.



Datenschutzerklärung
Powered by phpBB © 2001, 2002 phpBB Group

'AFclean' Theme by Matthias Overloeper, based on 'AmigaFuture Deluxe' by Tristan Mangold