Vesalia Amiga Future Archive

User
Username:

Password:

 Remember me



I forgot my password

Don't have an account yet?
You can register for FREE

Language:

 

» Home
» Mag Member
» News View
» News Tell
» News Setting
» Everywhere
 
Amiga Future
» Info
» Content List
» Article-Database
» Merchandising
» Shop
» Downloads
 
Community
» Forum
» Gallery
» Calendar
 
Knowledge
» Amiga Software
» Amiga Cheats
» Amiga FAQ
» Forum FAQ
» Links
 
Service
» Jobs
» Webmaster
» Advertising
» Contact/Imprint
» Privacy Policy

Searching

Advanced Search

Anzeigen
Bitte unterstützt uns durch Einkäufe bei Amazon:

Deutschland
Österreich
UK
France
Canada
Italia
Espana


Spenden
Donate
Amiga Future

Restauration A500+

 
Post new topicReply to topic Amiga Future Forum Index -> Amiga und Kompatible Hardware
View previous topic :: View next topic 
Author Message
Turbodriver
Grade reingestolpert
Grade reingestolpert


Joined: 09 Sep 2018
Posts: 3
Location: Tholey

PostPosted: 09.09.2018 - 12:15    Post subject: Restauration A500+ Quote

Hallo,

nachdem ich dieses Jahr auf der Gamescom erneut am Stand der Amiga Future aufgeschlagen bin hat's mir auf dem Heimweg bereits derart in den Fingern gejuckt meinen alten 500+ auszugraben und ihm neues Leben einzuhauchen...
Auch aus dem Grund, um meinen Sprösslingen (12 u. 16J) mal das Erlebnis Amiga bieten zu können und zu zeigen, was mit 880kB Floppydisks alles möglich ist.
Oh Mann, bin wieder voll infiziert, und das in meinem Alter 😁

Zur Maschine: der Amiga ist ein A500+ 1MB RAM Rev.8a mit Fat Agnus 8375 und HiRes Denise, im normalen 500 Gehäuse, Kickstartumschalter mit 1.3 und 2.04 sonst alles original.

Die Ernüchterung war leider groß, als ich nach dem Öffnen sehen musste welche Schäden der dieser kleine Backupakku angerichtet hat:
An den Sockeln von Gary und Agnus hatten sich die Pins aufgelöst, der Lötstopplack war an allen möglichen und unmöglichen Stellen unterwandert.
Habe die Sockel erneuert, alle Pins der Chips gereinigt, die beiden 74LS244 Brustreiber neben dem Akku erneuert, den Lötstopplack der unterwandert wurde entfernt, Leiterbahnen und Durchkontaktierungen gemessen und mich dann dazu entschlossen den Amiga mit dem originalen Netzteil mit Spannung zu versorgen.
Beim ersten Drücken des Netzschalters, zum Glück noch ohne angeschlossenen Amiga, knallte es aus dem Netzteil und ich durfte dann mit der Handyfunzel aus dem Keller nach oben wieder den Sicherungsautomat Einschalten gehen 😒
Die Glassicherung im Netzteil war schwarz, Gleichrichter, Schaltransistor und Elkos sowie die X u. Y Kondensatoren in Ordnung. Glassicherung ersetzt, nichts knallt, aber auch keine Ausgangsspannung... Fehler gesucht und gefunden, die Eingangsdrossel war defekt. In dieser war der Kupferlackdraht korrodiert und hat dadurch Kurzschluss verursacht. Drossel mit erstaunlicherweise gleichen Werten aus altem PC-Netzteil eingebaut, Einschalten - Netzteil läuft 😀.
Nun geht die eigentliche Misere los... Die LEDs der Tastatur leuchten beide Durchgehend, kein kurzes Ladegeräusch vom Motor des Floppys, kein Videosignal😭

Habe nun den Schaltplan vom 500'er Rev6 hier von der Seite ausgedruckt um nicht ganz im Dunkeln fischen zu müssen.

Habe als erstes den 28MHz Oszillator gemessen, ist o.k. das Signal liegt über 150 Ohm Widerstand an Pin 34:Agnus an.
Die 7MHz gehen an Pin 37:Agnus raus und liegen an Pin 18:CPU sowie an den anderen ECS Chips an.
An Pin 43-51:Agnus (DRA0-8) kann ich Signale sehen, an Pin 59-77:Agnus (A0-A19) ist 0V.
Reset an Pin18:CPU ist 5V wenn ich diesen gegen GND kurzschliesse bleiben die Signale an DRA0-8 stehen.

Am Kickstart-ROM Messe ich an allen Pin's nur Spannungen 0V, 2,5V und 5V aber keine Signale. Dies auch nicht beim Einschalten des Netzteils.

Kann mir jemand in etwa sagen, wie was beim booten zuerst erfolgt oder hat jemand schon eine Vermutung was den Amiga vom Booten abhällt?

Bin für alle Ideen und Hinweise offen und jetzt schon dankbar 🙃

V.l.G. Alex
Back to top   PDF
View user's profile Send private message
Turbodriver
Grade reingestolpert
Grade reingestolpert


Joined: 09 Sep 2018
Posts: 3
Location: Tholey

PostPosted: 12.09.2018 - 17:27    Post subject: Quote

Hallo, bin etwas weiter gekommen... 😊

Habe das ROMEN Signal, dieses war 5v gegen GND kurzgeschlossen und siehe da schon kommen Datensignale aus dem Kickstart-ROM ☺
Das Signal wird von Gary gesteuert, dieser sitzt sehr nah an dem ausgegasten Akku.
Konnte es kaum glauben, aber Gary gibt's neu!!! bei meinem lieblings Elektronikversand zu kaufen 🤗
Heute ist er angekommen, sofort vom Briefkasten in den Sockel und der Amiga funktioniert schon wieder ein Stück weiter😎
Videosignal kann ich mit dem Oszi messen, der Floppymotor läuft auch, auf dem Daten- und Adressbus tut sich was, jedoch blinkt die LED der Tastatur Mal hell Mal dunkel...
Werde mir nun ein RGB Kabel basteln und schauen, was Agnus als Farbfehler-Code ausgibt.
Back to top   PDF
View user's profile Send private message
Turbodriver
Grade reingestolpert
Grade reingestolpert


Joined: 09 Sep 2018
Posts: 3
Location: Tholey

PostPosted: 15.09.2018 - 20:02    Post subject: Quote

Und schon wieder etwas weiter... 😁
Der Amiga hatte 10 mal kurz, 1 Mal lang mit der Power LED geblinkt. Er versuchte dabei wohl die vom Kickstart ROM gebootete Software zu starten, hat es aber wegen Problemen mit dem Adress- Datenbussen nicht geschafft.
Habe nun alle Datenleitungen zwischen CPU, Agnus, RAM und TTL-Bauteilen ohmisch Durchgemessen und dabei tatsächlich ein paar defekte Durchkontaktierungen, vor allem an Agnus gefunden.
Hab sie zum Testen provisorisch überbrückt und nun läuft er wieder 😎
Am Diskettenlaufwerk musste ich noch den Microschalter zerlegen und mit Kontaktspray reinigen, leider funktionieren die paar Disketten die ich noch habe nur noch eingeschränkt. Irgendwann heulte der Motor und Gurufehler.. wie vor 25 Jahren 😀
Gotek USB, kleines OLED Display und Dreh-Encoder sind aber bereits unterwegs.
Back to top   PDF
View user's profile Send private message
daxb
AFF Profi
AFF Profi


Joined: 10 Nov 2002
Posts: 563


PostPosted: 16.09.2018 - 11:03    Post subject: Quote

Sieht ja echt übel aus, was die Batterie da verursacht hat. Aber Glückwunsch das du es repariert bekommen hast.
Back to top   PDF
View user's profile Send private message
Display posts from previous:   
Post new topicReply to topic Amiga Future Forum Index -> Amiga und Kompatible Hardware
All times are GMT - 11 Hours
Page 1 of 1

PDF


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Privacy Policy
Powered by phpBB © 2001, 2002 phpBB Group

'AFclean' Theme by Matthias Overloeper, based on 'AmigaFuture Deluxe' by Tristan Mangold