Anonymous




Register
Login

Amiga Future

Community

Knowledge

Service

Search




Advanced search

Unanswered topics
Active topics

Last Magazine

The Amiga Future 142 was released on the January 15th.

The Amiga Future 142 was released on the January 15th.
The Amiga Future 142 was released on the January 15th.

The Amiga Future 142 was released on the January 15th.
More informations

Social Media

Twitter Amigafuture Facebook Amigafuture RSS-Feed [german] Amigafuture RSS-Feed [english] Instagram YouTube

Advertisement

Partnerlinks

Frage zum Videoanschluss eines c128 D

Hier geht es um alle Computersysteme die keinen Platz im Amiga oder PC-Bereich haben.

Moderator: AndreasM

Post Reply
Gunny
AFF Profi
AFF Profi
Posts: 101
Joined: 12.05.2004 - 10:28

Frage zum Videoanschluss eines c128 D

Post by Gunny » 28.05.2009 - 12:04

Hi !
Ich habe mal meinen 128'er vom Dachbodeb geholt und ihn an einen 1084-Monitor angeschlossen. Dazu verwendete ich ein Monitorkabel ,das am 128'er Ende "rund" und am anderen Ende 3 chinch-Stecker hat(ihr wisst sicherlich was für eins ich meine ^^) Nun, leider musste ich feststellen, daß der Monitor nur ein schwarz-weiss-Bild des 64'er-Desktops zeigt. Jetzt haben ja der Monitor UND der 128'er beide auch einen 9-poligen Anschluss.
Ich meine mich zu erinnern mal einen Amiga über diesen 9-poligen Anschluss am 1084 betrieben zu haben. Mit dem 128'er funktioniert das aber anscheinend nicht. Das einzige Bild kriege ich nur wenn ich die C-Taste beim booten nicht drücke. Dann erscheint eine Oberfläche die ich noch nie sah ^^. Ich glaube es handelt sich dabei um den "anderen" dritten, auch im 128'er integrierten Computer(weiss jetzt nicht wie er heisst ^^)Wie dem auch sei, jetzt möchte ich wissen:

1. Ist es überhaupt möglich den C64 im 128'er über diesen Anschluss auf den Monitor zu kriegen ?
2. Ist es möglich daß der Monitor über den 9-poligen Anschluss noch "Farbe" zeigt oder wird dies sehr warscheinlich auch schwarzweiss sein ?
3. Hat einer ne Idee was dem Monitor "fehlt" ? Ist wohl schrottreif, was ^^.
4. Ich habe massenhaft alte PC-Monitore rumstehen. Beim Amiga weiss ich über Umstecker/Flickerfixer recht gut bescheid, aber gibt es da auch Adapter für c64/128'er ?

kudlaty
AFF Profi
AFF Profi
Posts: 429
Joined: 16.08.2005 - 10:29
Location: /dev/tty

Re: Frage zum Videoanschluss eines c128 D

Post by kudlaty » 28.05.2009 - 17:34

Gunny wrote:Ich habe mal meinen 128'er vom Dachbodeb geholt und ihn an einen 1084-Monitor angeschlossen. Dazu verwendete ich ein Monitorkabel ,das am 128'er Ende "rund" und am anderen Ende 3 chinch-Stecker hat(ihr wisst sicherlich was für eins ich meine ^^)
Das dürfte ein Y/C-Kabel sein (mit Luma, Chroma und Audio). Wenn Du das nicht in die passenden Buchsen gesteckt hast, kommt sowas raus:
Nun, leider musste ich feststellen, daß der Monitor nur ein schwarz-weiss-Bild des 64'er-Desktops zeigt.
Wie gesagt, Chroma und Luma. Das sind getrennte Signale, Chroma ist für die Farbinformationen zuständig und Luma für die Helligkeit (und Du hast offenbar nur letzteres benutzt).
Jetzt haben ja der Monitor UND der 128'er beide auch einen 9-poligen Anschluss. Ich meine mich zu erinnern mal einen Amiga über diesen 9-poligen Anschluss am 1084 betrieben zu haben. Mit dem 128'er funktioniert das aber anscheinend nicht.
Doch, das geht (zumindest bei vielen Monitoren). Im Gegensatz zum Amiga liefert der C128 aber kein analoges, sondern ein digitales RGB-Signal, das kann man oft am Monitor entsprechend umstellen (guck mal nach einem Schalter, an dem RGB-TTL steht).
Das einzige Bild kriege ich nur wenn ich die C-Taste beim booten nicht drücke. Dann erscheint eine Oberfläche die ich noch nie sah ^^. Ich glaube es handelt sich dabei um den "anderen" dritten, auch im 128'er integrierten Computer(weiss jetzt nicht wie er heisst ^^)
Hm. Ohne C= landet man im C128-Modus (Basic 7.0), wenn keine CP/M-Diskette eingelegt ist, mit C= im C64-Modus. Guck mal, wie die 40/80-Taste eingestellt ist, damit kannst Du die Ausgabe entsprechend umstellen (eben zwischen 40- und 80-Zeichen-Modus wählen).
4. Ich habe massenhaft alte PC-Monitore rumstehen. Beim Amiga weiss ich über Umstecker/Flickerfixer recht gut bescheid, aber gibt es da auch Adapter für c64/128'er ?
Noch nicht, aber bald.

Gunny
AFF Profi
AFF Profi
Posts: 101
Joined: 12.05.2004 - 10:28

Post by Gunny » 28.05.2009 - 23:55

Schonmal vielen Dank für die ausführlichen Antworten. Werde es morgen mal überprüfen und dann erneut berichten.

Gunny
AFF Profi
AFF Profi
Posts: 101
Joined: 12.05.2004 - 10:28

Post by Gunny » 29.05.2009 - 09:19

Also ich habe nochmal alles überpfrüft und es gab leider keine Änderung :-(.
Beim Monitor handelt es sich konkret um einen "1084S-P1". Er hat am 9-poligen Anschluss einen Knopf der einrasten kann und an ihm steht "Ana..." und "TTL", was dann wohl laut deiner Erklärung der Unterschied zwischen Amiga und c64 wäre. Weiter rechts sind dann noch 2 weitere solcher Knöpfe mit "CVBS/RGB" und "CVBS/LCA", von denen wohl dann jeweils einer für die beiden Anschlussmöglichkeiten da sind. Soweit macht das ja alles Sinn. Hab auch alle Bauteile im Monitor abgeklopft, aber das mal kurz Farbe aufblinkt oder ähnliches - Fehlanzeige. :cry: Ist wohl wirklich nix mehr zu machen.

Da gibt es aber noch eine Sache die ich nicht verstehe: WENN ich den 128'er auf "80-Zeichen-modus" stelle und den 9-poligen Anschluss verwende und richtig einstelle und alles, dann KOMMT auch ein Bild. Allerdings nicht das grün-schwarze Bild mit Rand welches ich vom 128'er kenne sondern ein komplett schwarzes Bild mit weissbläulicher Schrift. Ansonsten ist alles wie sonst, ich kann die Disk aufrufen und alles. Wieso kommt ein Bild mit dem 128'er über diesen Anschluss und mit dem 64'er nicht ?

kudlaty
AFF Profi
AFF Profi
Posts: 429
Joined: 16.08.2005 - 10:29
Location: /dev/tty

Post by kudlaty » 29.05.2009 - 13:15

Gunny wrote:Beim Monitor handelt es sich konkret um einen "1084S-P1". Er hat am 9-poligen Anschluss einen Knopf der einrasten kann und an ihm steht "Ana..." und "TTL", was dann wohl laut deiner Erklärung der Unterschied zwischen Amiga und c64 wäre.
Zwischen Amiga und C128, der C64 hat kein RGB. Lass den Knopf für den C128 in der TTL-Stellung.
Weiter rechts sind dann noch 2 weitere solcher Knöpfe mit "CVBS/RGB" und "CVBS/LCA", von denen wohl dann jeweils einer für die beiden Anschlussmöglichkeiten da sind.
Mit CVBS/RGB schaltest Du zwischen Composite Video und RGB um. Für den 80-Zeichen-Modus (9-pol. Anschluss) auf RGB stellen, für den 40-Zeichen Modus (8-pol. runder Anschluss) auf CVBAS.

CVBS/LCA schaltet zwischen FBAS und Y/C um (LCA ist kurz für die schon erwähnten Y/C-Komponenten Luma und Chroma plus A für Audio). Bei deinem Kabel wäre es dann halt LCA.
Da gibt es aber noch eine Sache die ich nicht verstehe: WENN ich den 128'er auf "80-Zeichen-modus" stelle und den 9-poligen Anschluss verwende und richtig einstelle und alles, dann KOMMT auch ein Bild. Allerdings nicht das grün-schwarze Bild mit Rand welches ich vom 128'er kenne sondern ein komplett schwarzes Bild mit weissbläulicher Schrift. Ansonsten ist alles wie sonst, ich kann die Disk aufrufen und alles. Wieso kommt ein Bild mit dem 128'er über diesen Anschluss und mit dem 64'er nicht ?
Weil der C64 nie einen solchen Anschluss oder 80 Zeichen (jedenfalls nicht ab Werk) hatte, das bleibt dem C128 vorbehalten.

Das Bild, das Du da siehst, dürfte CP/M sein. Tu ma Diskette raus. :)

Post Reply